Go Back   Hyundai Forum - Hyundai Enthusiast Forums > Vehicle Line Up > Hyundai Santa Fe
Sign in using an external account
Register Forgot Password?
Search

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 12-13-2004, 03:36 PM
 
Join Date: Dec 2004
Location: Canada
Posts: 1
Default engine hesitation at take off

our new 2004 Santa Fe GLS 2.7 engine, is a real beauty except for one thing, - on occasion, not often, the engine hesitates as if the injector was not getting gas. Just a stutter, then it returns to normal operation. Cruise control is off and the start up is normal but when you step on the gas to pull away from the curb there is the occasional small stutter from the engine. We took it back to the dealer and they changed a couple of things in the computer but after a thousand kms or so the phantom showed up again. Unfortunately the dealer workorder does not specify exactly what they did to remedy the problem. Anyone out there with a similar problem and what was the remedy.....
Reply With Quote
Sponsored Links
  #2  
Old 02-27-2005, 02:43 AM
 
Join Date: Feb 2005
Posts: 6
Default RE: engine hesitation at take off

Take note to see if it only happens on the initial take-off after start-up. Hyundai has a ecm reprogram for a "triple bump" stutter under those conditions
Reply With Quote
  #3  
Old 05-15-2005, 11:42 PM
kev kev is offline
 
Join Date: May 2005
Posts: 1
Default RE: engine hesitation at take off

We purchased a 2004 Sante Fe and have had the same problem. We've had it in 3 times and they can't seem to find the problem. We've learned to ignore it, but I would rather it be fixed. Other than that, we are well satisfied with it.
Reply With Quote
  #4  
Old 06-08-2005, 07:41 PM
 
Join Date: Jun 2005
Posts: 1
Default RE: engine hesitation at take off

I have had the same problem with my new 2004 Santa Fe. It hesitates about 3 times during take off from a curb. I let off the gas
a bit and it picks up O.K. after that. Usually happens when I am just starting off after the engine has been cold for awhile. I have had
2 program updates to the control computer but no success in getting rid of the hesitation. I don't know if my dealership would agree to
replace the computer under warranty just to get rid of a minor (for now) annoyance. Engine is 2.7 L.



Reply With Quote
  #5  
Old 06-10-2005, 12:13 AM
Senior Member
 
Join Date: Jun 2005
Location:
Posts: 138
Default RE: engine hesitation at take off

Zachnole Is your vehicle all wheel drive? Or is it just a plain 2.7 FWD?
__________________
Hyundai platinum technician
Reply With Quote
  #6  
Old 09-06-2005, 07:08 PM
 
Join Date: Sep 2005
Posts: 1
Default RE: engine hesitation at take off

I'm experiencing the same problem with my 2004 Sante Fe 3.5L (AWD). I experience a skip when accelerating and a skip and a buck when stationary (foot on brake and in drive). It's currently at the dealer now and they don't have a clue. Any suggestions?
Reply With Quote
  #7  
Old 09-15-2005, 12:49 PM
 
Join Date: Sep 2005
Posts: 2
Default RE: engine hesitation at take off

We have a 2004 2.7 AWD that had the same problem as well. Usually would happen when cold and first starting out from the curb - got so bad that our heads were bobbing back and forth on startup. Took it into the dealership and they updated the ecm. Works OK now (well, almost anyway - still get a bit of a stutter once in awhile). The salesperson tried to tell us that it was 'regular wear and tear' of the vehicle during the 'break-in' period.
Reply With Quote
  #8  
Old 09-19-2005, 07:31 PM
 
Join Date: Sep 2005
Location:
Posts: 2
Default RE: engine hesitation at take off

I have a 2005 GLS 3.7, and I have experienced a 2 stalls in the 5 months I have had it. It is truly weird as those two times there was nothing special about the incident. Other than that it has been working fine, but ran into a problem with my front bumper as noted in my new post. Hope this hesitation doesn't become more of an issue.
Reply With Quote
  #9  
Old 11-21-2005, 05:23 PM
TNT TNT is offline
 
Join Date: Nov 2005
Location:
Posts: 15
Default RE: engine hesitation at take off

3.7L....nice.
__________________
'03 Tiburon GT V6 6-speed (Black)
-USP3 now w/ '04 and '05 silver interior accents
-Injen CAI/Red groundwires/ Greddy strut bar
-SSA Catback
-KDM Full Chrome headlights
-Helios 6000K HIDs w/ Nokya yellow fogs
-Alpine HU/amp & JL 12W3
Reply With Quote
  #10  
Old 12-17-2005, 07:26 PM
 
Join Date: Nov 2005
Location:
Posts: 16
Default RE: engine hesitation at take off

theres a bulletin about this problem, check the air intake hose after the mass air flow sensor, it might be loose. i had one today at my work that had the same problem, open the hood, and the air hose was barley touching the mass air flow sensor.
Reply With Quote
Old 12-17-2005, 07:26 PM
 
 
 
Reply



Tags
03, accent, ecm, engine, fe, genesis, hesitating, hesitation, hyundai, reprogram, reprograming, santa, startup, stuttering, tiburon


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
Hyundai Custom Wheels

All times are GMT -5. The time now is 10:58 PM.

Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.