car in safety mode - 3 warning lights - Hyundai Forum - Hyundai Enthusiast Forums


Hyundai Santa Fe This compact sport utility vehicle offers the buyer the safety of an SUV without the hefty price tag or fuel bill.

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 03-06-2014, 12:32 AM
Junior Member
Thread Starter
 
Join Date: Mar 2014
Posts: 3
Default car in safety mode - 3 warning lights

Hi everyone im new here and apologise if this issue has been raised before I tried looking and couldn't find it in a thread

I recently purchased a 2007 santa fe elite 2.7l with only 59860 on the clock I have taken it for 2 long drives in the last 3 weeks each way was over 350km and i had no issues (needless to say I was over the moon as the car ran so well)

Well that changed a few days ago I got in the car and when I started the car I noticed a malfunction warning light and also spotted the eps off light was on (unable to remove the light) as well as the 4WD system warning light I turned the car off started it and the only light remaining was the MWL I drove approx 15 min away to the shops (i read that sometimes the light can come on and disappear after driving if not to get the car to a dealer asap).

When i got back in the car the light was gone

This morning I jumped into the car and the lights were all back and have not gone away..... when I start the car up the mwl appears when i go into drive the other 2 warning lights appear and the car doesn't go faster than 20-30kms

Ive just purchased the car and I really hope it is going to be something cheap to fix and not something that breaks my bank Ive already spent a fair amount on the car to snazzy it up a little.... and even had it serviced before the due date to ensure all was okay before i drove any long distances after all this car is to do me for many many years yet I know its not new but to me it is

Your advise and wisdom will be greatly appreciated!

I have asked a mechanic to look at it.... that call was made 6 hours ago and im still waiting for him to arrive Im just hoping that someone can ease my stress or give me a few things to try hopefully ive given enough information for someone to do this if not please ask

Thanks for your time
Reply With Quote
  #2  
Old 03-06-2014, 09:28 AM
NovaResource's Avatar
Super Moderator
 
Join Date: May 2005
Location: Cyberspace
Posts: 5,301
Default

My best guess would be a broken tone ring on the front wheel speed sensor. A common issue with Santa Fe's. They rust and crack.



https://www.hyundaiforum.com/forum/h...s-light-10764/

https://www.hyundaiforum.com/forum/h...engaged-12379/
Reply With Quote
  #3  
Old 03-09-2014, 08:50 PM
Junior Member
Thread Starter
 
Join Date: Mar 2014
Posts: 3
Default

Hi Nova

Thanks for the reply i will have a look but i dont have issues with the cruise control so it may not be related to my issue but i will still look

the mechanic came and he cleared the 3 warning codes... i dont have the codes but he did say one of the codes was one he had never heard of and would speak to someone else who specialises in codes etc that was if the issue came back he was just hoping it may have been some dust etc interfering

No such luck

it drove okay once and now they have re appeared ;-( I am not 100% sure but it looks like the car may do this when it is cold when the lights came on today I turned the car off which cleared the 4wd one and the eps then i started the car and let it warm up (rather than driving in 2 mins i sat there for at least 5) when i went into drive i only have the malfunction error appearing... the mechanic is calling past tomorrow so i will have to mention it and cross my fingers that the issue is related to driving the car when its not warm enough..... fingers crossed
Reply With Quote
  #4  
Old 03-10-2014, 07:11 AM
NovaResource's Avatar
Super Moderator
 
Join Date: May 2005
Location: Cyberspace
Posts: 5,301
Default

Well, without the codes that's not much we can do.
Reply With Quote
  #5  
Old 03-11-2014, 02:46 AM
Junior Member
Thread Starter
 
Join Date: Mar 2014
Posts: 3
Default

Hi i have been told today the cause is the throttle body (sensors) so the whole part needs replacing, so i have found a genuine part for the same price as they want for a used one here in AU... now i just cross my fingers the car holds out for 8 days till the part arrives!! I will get the codes and post them on here so that it may assist someone else if they have the same issue
Now i realise the importance of codes ive always had older cars with no codes just issues which had to be worked out the hard way.... i guess codes are a good thing if you know what they mean :-)
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2010 Hyundai Genesis sedan earns IIHS Top Safety Pick swenrac Hyundai Genesis Sedan 2008-Present 1 05-25-2010 01:19 PM
Hatch safety recall GreyTouring Hyundai Elantra Touring / i30 2 09-09-2009 07:15 AM
Neutral Safety Switch Brant General Tech Help 0 11-14-2006 01:12 PM
Neutral Safety Switch Brant Hyundai Accent 0 11-14-2006 01:09 PM
Can we change from 'D' to sport mode while car is moving? buddlake07828 Hyundai Sonata 2 09-28-2006 02:15 AM


Tags
2007, fe, hyundai, mod, mode, safe, santa, sante

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 06:25 PM.


© 2018 MH Sub I, LLC dba Internet Brands
We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.