wiper fluid doesnot work - Hyundai Forum - Hyundai Enthusiast Forums

Hyundai Sonata The Sonata has grown to be the premier mid-sized sedan of the Hyundai name with the many interior options and the powerful V6 engine.

wiper fluid doesnot work

Reply

 
 
 
  #1  
Old 07-21-2010, 10:11 AM
Junior Member
Thread Starter
Join Date: May 2008
Posts: 14
Default wiper fluid doesnot work

i have 2002 sonata i push the wiper in for fluid to come out nothing happens . any suggestions
 
Reply With Quote
  #2  
Old 07-21-2010, 04:08 PM
Senior Member
Join Date: Aug 2008
Location: Indianapolis, Indiana
Posts: 111
Default

Check to see if the pump runs when the button is pressed. Have a helper press the button while you listen at the washer bottle... you should be able to hear the pump motor run. If no sound is heard, you must check for power & a good ground at the pump electrical connector that is plugged into the motor assy that is mounted at the bottom of the washer bottle.
 
Reply With Quote
  #3  
Old 07-21-2010, 09:54 PM
Senior Member
Join Date: Mar 2010
Posts: 900
Default

Replace the wash pump assembly, common fail part with age on the Hyundai product
 
Reply With Quote
  #4  
Old 04-25-2016, 01:56 AM
Junior Member
Join Date: Jun 2013
Posts: 18
Default

The washer fluid could be frozen.
 
Reply With Quote
  #5  
Old 04-25-2016, 07:56 PM
Senior Member
Join Date: Sep 2015
Location: Albany/NY/USA
Posts: 784
Default

That was a little less than six years ago.
I hope by now that they would have had it fixed.
 
Reply With Quote
  #6  
Old 04-26-2016, 04:00 PM
Junior Member
Join Date: Jun 2013
Posts: 18
Default

Originally Posted by avisitor View Post
That was a little less than six years ago.
I hope by now that they would have had it fixed.
I see that the post is a few years old. Someone with the same problem will look at this and maybe it will help. I found it after six years. 😀😀
 
Reply With Quote
  #7  
Old 04-27-2016, 09:56 PM
Senior Member
Join Date: Sep 2015
Location: Albany/NY/USA
Posts: 784
Default

Originally Posted by otis66 View Post
I see that the post is a few years old. Someone with the same problem will look at this and maybe it will help. I found it after six years. ����
sbr711 is a Hyundai mechanic.
He probably gave the correct advice and it was fixed.

It is unfortunate that people don't come back and post their fixes.
 
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
weikelm
Hyundai Accent
0
03-04-2013 11:57 AM
cgrosso74
Hyundai Santa Fe
5
04-02-2012 04:36 AM
wessock
Hyundai Elantra Touring / i30
1
01-18-2012 11:54 AM
v1vrfly
Hyundai Santa Fe
8
02-14-2011 08:52 AM
keldrin
Hyundai Elantra Touring / i30
3
01-22-2010 09:26 AM


Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory