Go Back   Hyundai Forum - Hyundai Enthusiast Forums > General Hyundai Forums > General Tech Help
Sign in using an external account
Register Forgot Password?
Search

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-21-2009, 02:16 AM
 
Join Date: Jan 2009
Posts: 3
Default 2000 hyundai has no spark

Driving to work, car shut off with check engine light on. Made it to Autozone next day and the code said it was the crank sensor. Had to order it and when I put the new one in the car ,would not start. I put the original one back in and it would start. I repeated this 3 times and after the last time I put the original one back in, it would not start. I checked the spark and doesn't have one.I had a spare 2000 motor and replaced the cam sensor, coil pack and module and I replaced the crank sensor with 3 different ones. Checked the fuses and all OK. Took it to a garage andeven had a hyundai tech look at it and can't figure it out. Need Help
Reply With Quote
Sponsored Links
  #2  
Old 01-21-2009, 06:42 AM
Banned
 
Join Date: Sep 2008
Posts: 1,254
Default RE: 2000 hyundai has no spark

When you take the old sensor out, sometimes the rubber gasket will remain in the hole. When this happens, and you put the new one in with a new gasket, it holds the sensor too far away from the crank to get a signal. So the question is:

When you took the old one out, did you look inside and verify that all the old gasket was removed too?

If so, what was the code you got?

Last edited by NovaResource; 09-20-2011 at 07:43 PM.
Reply With Quote
  #3  
Old 01-21-2009, 11:49 AM
 
Join Date: Jan 2009
Posts: 3
Default RE: 2000 hyundai has no spark

Yes I did check the o ring.There's just one. and there's no code as of right now.
Reply With Quote
  #4  
Old 01-21-2009, 05:04 PM
Banned
 
Join Date: Sep 2008
Posts: 1,254
Default RE: 2000 hyundai has no spark

Need to know the actual code you got to verify. Sometimes the crank sensor gets confused with the cam sensor, even the Hyundai repair manual got it confused. If you replaced the crank sensor thinking it's the cam sensor (or visa/versa) then that's the problem.

Last edited by NovaResource; 09-20-2011 at 07:43 PM.
Reply With Quote
  #5  
Old 01-22-2009, 12:20 AM
 
Join Date: Jan 2009
Posts: 3
Default RE: 2000 hyundai has no spark

Sorry I don't have the code. I did change cam sensor with a differnent one.It was off a 2000 motor.
Reply With Quote
  #6  
Old 01-22-2009, 06:14 AM
Banned
 
Join Date: Sep 2008
Posts: 1,254
Default RE: 2000 hyundai has no spark

Get a code scanner and see if there is some codes now. Obviously something is REALLY not working, there should be a code. I'm not sure, but I think Autozone will lend you a scanner for free.

Last edited by NovaResource; 09-20-2011 at 07:44 PM.
Reply With Quote
Old 01-22-2009, 06:14 AM
 
 
 
Reply



Tags
2000, crank, hyundai, repair, spark, sparkreplaced


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
Hyundai Custom Wheels

All times are GMT -5. The time now is 03:21 AM.

Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.