General Tech Help Good at troubleshooting? Have a non specific issue? Discuss general tech topics here.

2013 Elantra P0016 & P0340 issue

  #1  
Old 05-18-2018, 02:44 PM
Junior Member
Thread Starter
Join Date: May 2018
Posts: 1
Default 2013 Elantra P0016 & P0340 issue

Hi all,

I have a '13 Elantra GLS 1.8. Recently, the engine light came on and the P0016 code came up for camshaft issue. I took it to a mechanic friend and he thought the sensors were good so I went ahead and replaced the intake VVT. That didn't work and a day later car would not start. I then replaced both cam sensors. Now the P0016 is gone but new P0340 came up. These are brand new OEM sensors. I even put old ones back in and still 340 code. I get power to the sensors.

I then replaced exhaust VVT and still 340 code and won't start. I've read this engine has a maintenance free timing chain that doesn't need to be replaced.

Anything else I can try? I don't want to take to dealer if possible.

thanks
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
fabher
Hyundai Accent
5
09-18-2018 10:24 AM
Jsb
General Tech Help
0
01-24-2018 12:32 PM
Moondog66
Hyundai Elantra
7
07-22-2016 11:23 PM
Accent09GLS
Hyundai Accent
0
07-04-2015 12:15 PM
gojan
Hyundai Sonata
0
06-06-2010 05:17 PM


Thread Tools
Search this Thread
Quick Reply: 2013 Elantra P0016 & P0340 issue


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.