Car has issues when starting at times - Hyundai Forum - Hyundai Enthusiast Forums

Go Back  Hyundai Forum - Hyundai Enthusiast Forums > Vehicle Line Up > Hyundai Getz
Reload this Page >

Car has issues when starting at times

Hyundai Getz Offering a sportier look than the Atos, the Getz preserves the economy of the sub compact market in both the 2 and 4 door models.

Car has issues when starting at times

Reply

 
 
 
  #1  
Old 01-12-2016, 06:52 AM
Junior Member
Thread Starter
Join Date: Jan 2016
Location: Johannesburg
Posts: 4
Default Car has issues when starting at times

Hello

I brought a 2003 Getz last year (Nov). Ever since I brought the car at times it would start immediately when you switch the car off and at times it won't. We did a battery check and replaced the main and ignition relay but it's still doing it. The car's immobilizer system has been removed. The dealer where we brought the car from did contact the owner of the car and she says the car didn't do it with her. When we brought the car the engine was steamed cleaned so that the plugs was under water and we could hardly take the car for a test drive. Please if anyone can help me it would be great. Our mechanic isn't much help and I don't really want to take the car to a dealer as I don't have cash.

Thanks for the help.
 
Reply With Quote
  #2  
Old 01-12-2016, 09:55 PM
Senior Member
Join Date: Sep 2015
Location: Albany/NY/USA
Posts: 795
Default

Sounds like the steam cleaning did a number on your car's electrical system.
Is it a hard failure? Will it not start all the time?
If it is intermittent then it will be hard to figure out
If you can get the engine to run then let it run til it get hot and gets a chance to dry out

The last thing one can do is back to basics ... when it fails to start
Check for spark, listen for the fuel pump to turn on when the key is turned to the on position,
check for injector pulse, check fuel rail for pressure
(maybe even throw a bottle of fuel cleaner in the gas tank)
 
Reply With Quote
  #3  
Old 01-13-2016, 01:20 AM
Junior Member
Thread Starter
Join Date: Jan 2016
Location: Johannesburg
Posts: 4
Default

Hi.

The engine was cleaned last year so I'm sure it is dry by now. The fuel pump works as you hear it switches on when you start the car.

I don't think it is mechanical as it will start after the car stood a while then most of the times after you have driven either a short distance of a long distance when you switch the car off it wont' start when you start it. You hear a loud click then nothing. Then either after about a couple of seconds or minutes the car starts again no problem. If you push start the car it also starts no problem. They removed the mobilizer not sure it that might be the cause. Most of the times when you drive with the aircon on it does it as well, but lately it is happening almost every time. In the mornings when I drive to work, when I get to work I switch the car off and then if I want to start it again it clicks and then nothing.
 
Reply With Quote
  #4  
Old 01-14-2016, 12:47 AM
Senior Member
Join Date: Sep 2015
Location: Albany/NY/USA
Posts: 795
Default

That loud click and then nothing sounds like a bad ground
Check all the grounding straps that go to the engine block by taking the bolts or nuts off and cleaning the area with a wire brush
Then put it back together.
Also check the terminals on the battery and cables for corrosion

The other thing it could be is the starter relay.
Since trying to start the engine only gets a click and nothing (no cranking)
This can be tested. Check out youtube videos on how to check a starter relay

Push starting the vehicle by passes the starter system which cranks the engine
I have also read where push starting a car will also by pass the cam sensor for starting .. not sure
 
Reply With Quote
  #5  
Old 01-14-2016, 01:04 AM
Junior Member
Thread Starter
Join Date: Jan 2016
Location: Johannesburg
Posts: 4
Default

Thank for the advise. I will check the everything this weekend. The battery has been tested, and there is no corrosion on it, one thing I have noticed is there is a "clamp"over the positive that gets tighten with a bolt on top. When we first looked at the battery that was a bit loose and we tightened it but it looks like its a bit worn out. Will look at that again.
 
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
NikkiS
Hyundai Tucson
14
07-22-2018 08:58 AM
rosie
Hyundai Sonata
18
06-13-2013 01:07 PM
Santa Don
Hyundai Santa Fe
0
10-09-2012 09:58 PM
kraig37
Hyundai Accent
1
05-29-2012 08:30 AM
Karl99
Hyundai Sonata
3
11-07-2011 09:16 AM


Thread Tools
Search this Thread
Quick Reply: Car has issues when starting at times


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.