Rough Idle and stall on cold start - Hyundai Forum - Hyundai Enthusiast Forums

Go Back  Hyundai Forum - Hyundai Enthusiast Forums > Vehicle Line Up > Hyundai XG 350
Reload this Page >

Rough Idle and stall on cold start

Hyundai XG 350 The mid-sized luxury model

Rough Idle and stall on cold start

Reply

 
 
 
  #1  
Old 09-22-2017, 01:14 PM
Junior Member
Thread Starter
Join Date: Sep 2017
Posts: 23
Question Rough Idle and stall on cold start

Hello,

I have an XG350 2004 with 60k miles on it. The first start of the day is rough. The car idles very very rough and and sometimes stalls. The engine will sometimes rev up by its self just before stall.

Im in the process of changing all plugs and EGR valve. Any one else had this or can point me in the right direction? Once its warm it idles well.

The ECU throws codes of random misfile or sometimes a couple specific cylinders.

Thanks for the help!

Bruce
 
Reply With Quote
  #2  
Old 09-22-2017, 01:55 PM
Junior Member
Thread Starter
Join Date: Sep 2017
Posts: 23
Default

Could it be the IAC - Idle Air Control Valve? I almost feels like the engine is starving for oxygen.
 
Reply With Quote
  #3  
Old 09-22-2017, 05:21 PM
Senior Member
Join Date: Sep 2015
Location: Albany/NY/USA
Posts: 795
Default

IAC or EGR
 
Reply With Quote
  #4  
Old 09-22-2017, 08:50 PM
Junior Member
Thread Starter
Join Date: Sep 2017
Posts: 23
Default

Thanks EGR is first. We will see!
 
Reply With Quote
  #5  
Old 10-02-2017, 07:35 PM
Junior Member
Thread Starter
Join Date: Sep 2017
Posts: 23
Default

Here is what I have changed (shooting from the hip somewhat):

*EGR Valve
*Idle Air Control Valve
*Injectors (All 6)
*Plugs (NGK Iridium)
*Cleaned upper inlet manifold and throttle body completely and resealed.
*New throttle body gasket and Intake manifold gasket.

It ran smoother and I thought I had it.....but NOPE. Today after sitting 9Hrs at work I get in and ....grumble grumble grumble, problem is still there!

So I think it is a fuel delivery issue.

ANY THOUGHTS?

Next:
*Fuel pump
*Fuel pressure regulator
...
*burn the car to the ground. (JOKING)

ALL HELP APPCIATED!
 
Reply With Quote
  #6  
Old 10-02-2017, 09:17 PM
Senior Member
Join Date: Sep 2015
Location: Albany/NY/USA
Posts: 795
Default

Well, it sounds to me like you got all the bases covered
And it should be working well

Is there water in the gas tank?
Maybe some fuel cleaner??
 
Reply With Quote
  #7  
Old 10-04-2017, 06:44 PM
Junior Member
Thread Starter
Join Date: Sep 2017
Posts: 23
Default

tried fuel cleaner.
 
Reply With Quote
  #8  
Old 10-07-2017, 08:34 AM
Senior Member
Join Date: Sep 2015
Location: Albany/NY/USA
Posts: 795
Default

Then it seems it has got to be the pump or regulator
 
Reply With Quote
  #9  
Old 10-07-2017, 01:57 PM
Junior Member
Thread Starter
Join Date: Sep 2017
Posts: 23
Default

My clue that is pressure regulator:

-Black plugs
-Bad MPG
 
Reply With Quote
  #10  
Old 10-20-2017, 08:48 AM
Junior Member
Join Date: Oct 2017
Posts: 1
Default

Crank shaft position sensor?
 
Reply With Quote

Thread Tools
Search this Thread
Quick Reply: Rough Idle and stall on cold start


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.