Rough Idle and stall on cold start - Hyundai Forum - Hyundai Enthusiast Forums


Hyundai XG 350 The mid-sized luxury model

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 09-22-2017, 01:14 PM
Junior Member
Thread Starter
 
Join Date: Sep 2017
Posts: 23
Question Rough Idle and stall on cold start

Hello,

I have an XG350 2004 with 60k miles on it. The first start of the day is rough. The car idles very very rough and and sometimes stalls. The engine will sometimes rev up by its self just before stall.

Im in the process of changing all plugs and EGR valve. Any one else had this or can point me in the right direction? Once its warm it idles well.

The ECU throws codes of random misfile or sometimes a couple specific cylinders.

Thanks for the help!

Bruce
Reply With Quote
  #2  
Old 09-22-2017, 01:55 PM
Junior Member
Thread Starter
 
Join Date: Sep 2017
Posts: 23
Default

Could it be the IAC - Idle Air Control Valve? I almost feels like the engine is starving for oxygen.
Reply With Quote
  #3  
Old 09-22-2017, 05:21 PM
Senior Member
 
Join Date: Sep 2015
Location: Albany/NY/USA
Posts: 589
Default

IAC or EGR
Reply With Quote
  #4  
Old 09-22-2017, 08:50 PM
Junior Member
Thread Starter
 
Join Date: Sep 2017
Posts: 23
Default

Thanks EGR is first. We will see!
Reply With Quote
  #5  
Old 10-02-2017, 07:35 PM
Junior Member
Thread Starter
 
Join Date: Sep 2017
Posts: 23
Default

Here is what I have changed (shooting from the hip somewhat):

*EGR Valve
*Idle Air Control Valve
*Injectors (All 6)
*Plugs (NGK Iridium)
*Cleaned upper inlet manifold and throttle body completely and resealed.
*New throttle body gasket and Intake manifold gasket.

It ran smoother and I thought I had it.....but NOPE. Today after sitting 9Hrs at work I get in and ....grumble grumble grumble, problem is still there!

So I think it is a fuel delivery issue.

ANY THOUGHTS?

Next:
*Fuel pump
*Fuel pressure regulator
...
*burn the car to the ground. (JOKING)

ALL HELP APPCIATED!
Reply With Quote
  #6  
Old 10-02-2017, 09:17 PM
Senior Member
 
Join Date: Sep 2015
Location: Albany/NY/USA
Posts: 589
Default

Well, it sounds to me like you got all the bases covered
And it should be working well

Is there water in the gas tank?
Maybe some fuel cleaner??
Reply With Quote
  #7  
Old 10-04-2017, 06:44 PM
Junior Member
Thread Starter
 
Join Date: Sep 2017
Posts: 23
Default

tried fuel cleaner.
Reply With Quote
  #8  
Old 10-07-2017, 08:34 AM
Senior Member
 
Join Date: Sep 2015
Location: Albany/NY/USA
Posts: 589
Default

Then it seems it has got to be the pump or regulator
Reply With Quote
  #9  
Old 10-07-2017, 01:57 PM
Junior Member
Thread Starter
 
Join Date: Sep 2017
Posts: 23
Default

My clue that is pressure regulator:

-Black plugs
-Bad MPG
Reply With Quote
  #10  
Old 10-20-2017, 08:48 AM
Junior Member
 
Join Date: Oct 2017
Posts: 1
Default

Crank shaft position sensor?
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Rough idle and start up mweide27 Hyundai XG 350 1 10-02-2017 10:49 PM
03 Santa Fe accelerator not working and brake causes engine to stall jkar Hyundai Santa Fe 1 01-07-2014 07:59 AM
rough idle after disconnecting and reconnecting battery jassmith Hyundai Accent 4 03-01-2008 07:16 PM
Rough idle and fuel smoke! jbragg923Justin General Tech Help 1 11-14-2007 09:47 AM
rough idle and windshield fluid pump keiffer Hyundai Sonata 0 06-09-2006 01:02 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 03:12 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.