Timing belt whine after replacement 2010 elantra - Hyundai Forum - Hyundai Enthusiast Forums


General Tech Help Good at troubleshooting? Have a non specific issue? Discuss general tech topics here.

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 04-16-2017, 11:41 PM
Junior Member
Thread Starter
 
Join Date: Apr 2017
Posts: 1
Default Timing belt whine after replacement 2010 elantra

I replaced the timing belt and water pump in my 2010 elantra, now there is a slight whine from the timing belt, confirmed from timing belt. I made sure and double checked that the tension is correct and within the white marked window. Not from any pulleys. What could this be? Could it be the new gates belt?
Reply With Quote
  #2  
Old 04-17-2017, 08:23 AM
Senior Member
 
Join Date: Sep 2015
Location: Albany/NY/USA
Posts: 482
Default

Quote:
Originally Posted by Milos View Post
I replaced the timing belt and water pump in my 2010 elantra, now there is a slight whine from the timing belt, confirmed from timing belt. I made sure and double checked that the tension is correct and within the white marked window. Not from any pulleys. What could this be? Could it be the new gates belt?
From your description, what else can it be??
Reply With Quote
  #3  
Old 08-11-2017, 05:32 PM
Junior Member
 
Join Date: Feb 2017
Posts: 8
Default

Did you replace it with an OEM Hyundai timing belt?
Reply With Quote
  #4  
Old 08-11-2017, 07:01 PM
Senior Member
 
Join Date: Sep 2015
Location: Albany/NY/USA
Posts: 482
Default

Did you also change the idler and tensioner pulleys??
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
P0016 code after timing belt change on 05 Elantra Moondog66 Hyundai Elantra 7 07-22-2016 11:23 PM
Valve noise after timing belt change. rm125chris General Tech Help 7 07-05-2009 01:00 AM
P0335 Crankshaft sensor code after Timing Belt Change XG300L miniwangja General Tech Help 8 06-12-2009 05:49 PM
Timing Belt Break in 9 month after a Garage changed a new. Robert Hyundai Sonata 2 10-19-2008 11:08 AM
Misses when accelerating after timing belt change tim.penfold Hyundai Accent 2 03-20-2008 02:32 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 10:43 PM.